石鑫华视觉论坛微信公众号:石鑫华视觉

 找回密码
 注册会员
查看: 397|回复: 0

[NI驱动程序] NI-XNET 2023 Q1 Driver Win11 32/64bit Eng/Ger/Jpn NI-XNET仪器驱动程序23.0下载

[复制链接]
  • TA的每日心情

    昨天 10:26
  • 签到天数: 3129 天

    连续签到: 13 天

    [LV.Master]2000FPS

     楼主| 发表于 2023-3-21 12:11:19 | 显示全部楼层 |阅读模式 来自:广东省东莞市 电信

    注册登陆后可查看附件和大图,以及购买相关内容

    您需要 登录 才可以下载或查看,没有账号?注册会员

    x
    NI-XNET 2023 Q1 Driver Win11 32/64bit Eng/Ger/Jpn NI-XNET仪器驱动程序23.0下载

    NI-XNET
    NI-XNET为配置、开发和调试应用程序提供支持,适用于汽车以太网、CAN、LIN和FlexRay网络的原型验证、仿真和测试。
    NI-XNET是一个NI仪器驱动程序,具有一组易用的常见功能,用于读写PXI、PCI、NI CompactDAQ和NI CompactRIO等不同平台的汽车以太网、CANI、LIN和FlexRay帧和信号。NI-XNET CAN、LIN和FlexRay接口经优化,适合需要对数百个CAN帧和信号进行高速实时操作的应用,如硬件在环仿真、快速控制原型、总线监控和自动化控制等。

    从NI-XNET 21.0版本开始,仅支持64位的Win10/WinServer 2016/WinServer 2019系统,但是仍然支持64位系统下的32位LabVIEW。

    Windows系统下(Linux和MAC系统下请自行了解清楚)NI的各种软件、模块、工具包、驱动程序,使用NI许可证管理器来激活的,绝大部分的都可以使用NI Lincense Activator来激活:NI序列号Serial Number生成激活工具NI License Activator,LabVIEW/VBAI/VDM/VAS等软件模块工具包破解工具不限版本http://visionbbs.com/thread-490-1-1.html

    视觉论坛的各种NI资源,除了视觉相关的模块有使用外,大部分的都不会使用,仅提供资源不提供技术支持。资源的下载地址一般会同时提供NI官方和百度网盘的地址。某些工具包NI地址失效或没有NI地址,只能使用百度网盘地址;如果百度网盘地址失效过期,可联系论坛客服更新。NI的服务器在美国,有时候速度很慢或下载容易出错,这样会造成安装时各种错误而无法安装。建议在下载完成后,对下载资源做校验和(NI一般会提供MD5或SHA256等)验证,与官方或视觉论坛提供的校验和对比,一致就可以安装;如不一致,则需要重新下载。视觉论坛早期下载上传的资源,基本上都是正常下载的资源;2019后下载的资源,都与NI的正确校验和对比过,保证是正确的资源才上传到百度网盘。校验和工具下载地址:文件Hash计算器FHash,文件校验和验证下载文件正确性验证,MD5值计算、SHA1值计算、SHA256值计算、CRC32值计算http://visionbbs.com/thread-26524-1-1.html

    发布日期:2023/2/3
    包含的版本:2023 Q1完整版,版本号23.0.0
    受支持的操作系统:
    Windows 11
    Windows Server 2022 64-bit
    Windows 10 64-bit
    Windows Server 2016 64-bit
    Windows Server 2019 64-bit
    语言:德语,日语,英文
    应用程序位数:32/64位
    校验和:
    文件大小: 1745616896 字节 (1.63 GB)
    修改日期: 2023-02-04 09:53
    MD5: 490e8465310574b68b671d71d5e531f3
    SHA1: 9c0b23383b7a02fe399ffec0e8329be5009229b6
    SHA256: 86fc6ee064be5c5e7cc92ec74b533846a66e5c2f7f4c66272a1f05457a959a73
    CRC32: f9cb6024

    百度网盘与NI官方下载地址:
    请注册登录机器视觉论坛账号,购买附件查看下载地址
    XNET2023Q1.txt (518 Bytes, 下载次数: 0, 售价: 10 元)

    NI-XNET 2023 Q1 Readme
    January 2023
    This file contains installation instructions and compatibility information for NI-XNET 2023 Q1.
    You can find more release information on ni.com.
    • NI-XNET Release Notes: Known issues, bugs fixed since the last release, and other notes about this release
    • NI-XNET Documentation: New features, behavior changes, and other documentation

    Overview
    Supported Operating Systems
    Application Software Support
    Installation Instructions
    Updated LabVIEW Compatibility Policy
    Product Security and Critical Updates
    New Features
    Supported Hardware
    Accessing the Documentation
    Finding Examples
    Automating the Installation of NI Products
    Using NI Software with Microsoft Windows 11
    Using NI Software with Microsoft Windows 10
    Unsupported Windows Operating Systems
    NI no longer supports Phar Lap ETS Real-Time Operating System

    Overview
    NI-XNET is an NI instrument driver that features a common set of easy-to-use functions for reading and writing Automotive Ethernet, CAN, LIN, and FlexRay data on many different platforms including USB, PXI, PCI, NI CompactDAQ, and NI CompactRIO.
    Supported Operating Systems
    NI-XNET 2023 Q1 supports the following operating systems:
    • Windows 11
    • Windows 10
    • Windows Server 2022
    • Windows Server 2019
    • Windows Server 2016
    • NI Linux® Real-Time
    Note  NI-XNET no longer supports any 32-bit Windows operating system. Refer to Unsupported Windows Operating Systems for more information about support for Microsoft Windows OSes.
    Application Software Support
    NI-XNET 2023 Q1 supports the following application software versions, including service packs. If you are not using NI application software, refer to Microsoft Visual Studio Support.
    Application Software
    Versions Supported by NI-XNET 2023 Q1
    LabVIEW2020, 2020 SP1, 2021, 2021 SP1, 2022 Q3, 2023 Q1
    LabVIEW Real-Time (RT)2020, 2021, 2022 Q3, 2023 Q1
    LabWindows™/CVI™2017 and later
    This product no longer supports LabVIEW NXG. Refer to LabVIEW NXG on ni.com for more information about LabVIEW NXG Life-Cycle Dates and driver version support.
    Microsoft Visual Studio Support
    If you are using the NI-XNET .NET Class Library, .NET Framework 4.0 (minimum) is required. The NI-XNET 2023 Q1 .NET Class Library can be used with Visual C# or Visual Basic .NET in any Visual Studio version that can target .NET Framework 4.0 or .NET Framework 4.5.
    To use the .NET API, you must install the .NET class libraries or the .NET wrapper in addition to the NI device driver. For information about versions of the .NET Framework and the drivers each supports, as well as the download location of the installer files, refer to .NET Resources for NI Hardware and Software.
    Installation Instructions
    Download the NI-XNET installer from ni.com/downloads. NI software includes NI Package Manager to handle the installation. Refer to the NI Package Manager Manual for more information about installing, removing, and upgrading NI software using Package Manager.
    After installing your software, you will need to activate it. Activating your software verifies the licenses associated with your NI account, so you can start using your software. You have different options for activation, based on your software and how it was purchased. Please visit ni.com/activate for more information on activation methods.
    Updated LabVIEW Compatibility Policy
    The "NI-XNET Support for LabVIEW" package supports applications using NI-XNET ​with LabVIEW 2023 or later. When installing NI-XNET, this package will be recommended if you have already installed LabVIEW 2023 or later and installs to the LVAddons directory.
    LVAddons directory location: "C:\Program Files\NI\LVAddons"
    Product Security and Critical Updates
    Visit ni.com/security to view and subscribe to receive security notifications about NI products. For information about critical updates from NI, refer to Available Critical and Security Updates for NI Software.
    New Features
    • Added support for LabVIEW 2023 Q1
    Supported Hardware
    Visit NI Hardware and Operating System Compatibility to view driver, desktop operating system, and real-time operating system support for individual hardware devices.
    To view information for your device:
    • Select your hardware model in the dropdown list on the page to view compatibility information for your device.
    • Type your hardware model number in the dropdown list on the web page to filter the list of available devices.
    Note: Some compatibility information may only be available in the archive attached to the NI Hardware and Operating System Compatibility page. For historic driver and OS support information, refer to the readme for the relevant driver version.
    Additional Hardware Support Information
    The following list details the hardware models supported in NI-XNET 2023 Q1:
    • USB-8501 Low-Speed/Fault Tolerant USB CAN Interface Device
    • USB-8502 High-Speed/FD USB CAN Interface Device
    • USB-8506 USB LIN Interface Device
    • PCI-8511 Low‑Speed/Fault-Tolerant CAN Interface Device
    • PCI-8512 High‑Speed/FD CAN Interface Device
    • PCI-8513 Software‑Selectable/FD CAN Interface Device
    • PCI-8516 PCI LIN Interface Device
    • PCI-8517 FlexRay Interface Device
    • PCIe-8510 PCIe Vehicle Multi-Protocol Interface Device
    • PXI-8511 Low-Speed/Fault Tolerant PXI CAN Interface Module
    • PXI-8512 High-Speed, Flexible Data Rate PXI CAN Interface Module
    • PXI-8513 Software-Selectable PXI CAN Interface Module
    • PXI-8516 PXI LIN Interface Module
    • PXI-8517 PXI FlexRay Interface Module
    • PXIe-8510 PXI Vehicle Multiprotocol Interface Module
    • PXIe-8521 100BASE-T1 PXI Automotive Ethernet Interface Module
    • PXIe-8522 1000BASE-T1 PXI Automotive Ethernet Interface Module
    • PXIe-8523 100/1000BASE-T1 PXI Automotive Ethernet Interface Module
    • PXIe-8623 100BASE-TX/1000BASE-T PXI Automotive Ethernet Interface Module
    • TRC-8542 CAN HS/FD Transceiver Cable
    • TRC-8543 CAN HS/FD or LS/FT Transceiver Cable
    • TRC-8546 LIN Transceiver Cable
    C Series modules:
    • NI 9860 C Series Vehicle Multiprotocol Interface Module
    • NI 9861 Low-Speed/Fault Tolerant C Series CAN Interface Module
    • NI 9862 High-Speed, Flexible Data Rate C Series CAN Interface Module
    • NI 9866 C Series LIN Interface Module
    Supported platforms for XNET C Series modules:
    • CompactDAQ—NI-DAQmx 17.1 (or later) is required for:
      • USB Chassis: cDAQ-9171, cDAQ-9174, cDAQ-9178, and cDAQ-9179
      • Ethernet Chassis: cDAQ-9181, cDAQ-9184, and cDAQ-9188
      • Wireless Chassis: cDAQ-9191
      • cDAQ Controller: cDAQ-9138 (Windows only) and cDAQ-9139 (Windows only)
      • cDAQ Controller: cDAQ-9132 (Windows and RT) and cDAQ-9134 (Windows and RT)
      • cDAQ Controller: cDAQ-9133 (Windows and RT) and cDAQ-9135 (Windows and RT)
      • cDAQ Controller: cDAQ-9136 (Windows and RT) and cDAQ-9137 (Windows and RT)
      • Ethernet Chassis: cDAQ-9185 and cDAQ-9189
    • CompactRIO—CompactRIO 20.0 (or later) and LabVIEW 2017 (or later) are required for the following targets:
      • Integrated CompactRIO Real-Time Controller: cRIO-906x, and cRIO-903x
      • Single-Board RIO: sbRIO-9627, sbRIO-9607
      • CompactRIO Real-Time Controller: cRIO-9032, cRIO-9037
      • CompactRIO Real-Time Controller: cRIO-9035 (Sync), cRIO-9039 (Sync)
      • When using a cRIO-903x or cRIO-906x, a bit stream is not needed with NI 986x modules in the project
      • When using a cRIO-903x, cRIO-906x, or sbRIO-96x7, installation in the "Other" programming environment is not supported
      • CompactRIO Real-Time Controller: cRIO-9040, cRIO-9042, cRIO-9043, cRIO-9045, cRIO-9046, cRIO-9047, cRIO-9048, and cRIO-9049
      • When using a cRIO-904x, NI 986x modules will only be usable in Real-Time mode, and no bit stream is necessary
    • CompactRIO—CompactRIO 20.0 (or later) and LabVIEW 2018 (or later) are required for the following targets:
      • CompactRIO Real-Time Controller: cRIO-9053, cRIO-9054, cRIO-9056, and cRIO-9057
      • When using a cRIO-905x, NI 986x modules will only be usable in Real-Time mode, and no bit stream is necessary
    • CompactRIO—CompactRIO 20.0 (or later) and LabVIEW 2019 (or later) are required for the following targets:
      • Single-Board RIO: sbRIO-9603, sbRIO-9608, sbRIO-9609, sbRIO-9628, sbRIO-9629, sbRIO-9638
      • When using an sbRIO-9603, sbRIO-9608, sbRIO-9609, sbRIO-9628, sbRIO-9629, or sbRIO-9638, NI 986x modules will only be usable in Real-Time mode, and no bit stream is necessary

    Note  NI-XNET software supports only NI Automotive Ethernet, CAN, FlexRay, and LIN hardware products. For information about software for CAN products from other vendors, refer to the documentation you received with those products.
    Accessing the Documentation
    Refer to the NI-XNET documentation, accessible from the Help menu in LabVIEW, for information about NI-XNET.
    Finding Examples
    Select Help»Find Examples from LabVIEW to launch the NI Example Finder.
    You can find Automotive Ethernet, CAN, FlexRay, and LIN examples under Hardware Input and Output in the Example Finder.
    LabVIEW examples for NI-XNET are located in the National Instruments\LabVIEW\examples\nixnet (From LabVIEW 2023 Q1 and later the examples can be found under LVAddons directory C:\Program Files\NI\LVAddons\ni-xnet\examples) directory. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.
    Automating the Installation of NI Products
    You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes.
    If the NI product you are installing uses Microsoft .NET 4.6.2, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.6.2 separately before you install NI software.
    For more information about automating the installation of NI products, refer to Automating an Installer in the NI Package Manager manual.
    Using NI Software with Microsoft Windows 11
    Microsoft Windows 11 is the latest version of the Windows operating system and features significant changes compared to previous versions. For more information about NI support for Windows 11, refer to NI Product Compatibility for Microsoft Windows 11.
    Using NI Software with Microsoft Windows 10
    For more information about NI support for Windows 10, refer to NI Product Compatibility for Microsoft Windows 10.
    Unsupported Windows Operating Systems
    NI-XNET no longer supports Windows Vista/XP/7/8.x, Windows Server 2003/2008/2012, or any 32-bit Windows operating system. Versions of this product that ship after May 1, 2021, may not install or execute correctly on these operating systems. For detailed information about NI operating system support, visit https://www.ni.com/r/win32bitsupport.
    NI No Longer Supports Phar Lap ETS Real-Time Operating System
    NI Software no longer supports Phar Lap ETS Real-Time Operating System. NI-XNET 2022 Q3 (and later) may not install or execute correctly on this operating system. For high-level information on the support roadmap for Phar Lap and its replacement, NI Linux Real-Time, visit ni.com/r/xf35k1. To find out what hardware is supported on PXI controllers running NI Linux Real-Time, visit ni.com/r/b7g5wi.
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册会员

    本版积分规则

    LabVIEW HALCON图像处理入门教程(第二版)
    石鑫华机器视觉与LabVIEW Vision图像处理PDF+视频教程11种全套
    《LabVIEW Vision函数实例详解》教程-NI Vision所有函数使用方法介绍,基于NI VISION2020,兼容VDM21/22/23
    LabVIEW图像处理教程
    机器视觉商城淘宝店铺
    视觉论坛充值赞助方法

    QQ|石鑫华视觉论坛 |网站地图

    GMT+8, 2024-3-2 01:44

    Powered by Discuz! X3.4

    © 2001-2024 Discuz! Team.

    快速回复 返回顶部 返回列表